Project

General

Profile

Error when installing on Linux

Added by Wim Coetzee over 6 years ago

When trying to install the first WAR on Alfresco Community 4.2.c, I get an error as follows:

[root@fc amps]# java -jar /opt/alfresco-4.2.c/bin/alfresco-mmt.jar install becpg-controls-core-1.5.0.amp /opt/alfresco-4.2.c/tomcat/webapps/alfresco.war -force
Exception in thread "main" java.lang.reflect.InvocationTargetException
at java.lang.reflect.Method.invoke(libgcj.so.10)
at com.simontuffs.onejar.Boot.run(Boot.java:287)
at com.simontuffs.onejar.Boot.main(Boot.java:137)
Caused by: java.lang.ExceptionInInitializerError
at java.lang.Class.initializeClass(libgcj.so.10)
at de.schlichtherle.truezip.fs.sl.FsManagerLocator.get(FsManagerLocator.java:53)
at de.schlichtherle.truezip.file.TConfig.<init>(TConfig.java:328)
at de.schlichtherle.truezip.file.TConfig.<clinit>(TConfig.java:273)
at java.lang.Class.initializeClass(libgcj.so.10)
at org.alfresco.repo.module.tool.ModuleManagementTool.<init>(ModuleManagementTool.java:97)
at org.alfresco.repo.module.tool.ModuleManagementTool.main(ModuleManagementTool.java:797)
at java.lang.reflect.Method.invoke(libgcj.so.10)
...2 more
Caused by: java.util.MissingResourceException: Bundle de.schlichtherle.truezip.fs.sl.FsManagerLocator not found for locale en_US by classloader gnu.gcj.runtime.SystemClassLoader{urls=[file:/opt/alfresco-4.2.c/bin/alfresco-mmt.jar], parent=gnu.gcj.runtime.ExtensionClassLoader{urls=[], parent=null}}
at java.util.ResourceBundle.getBundle(libgcj.so.10)
at java.util.ResourceBundle.getBundle(libgcj.so.10)
at java.util.logging.Logger.<init>(libgcj.so.10)
at java.util.logging.Logger.getLogger(libgcj.so.10)
at de.schlichtherle.truezip.fs.sl.FsManagerLocator$Boot.<clinit>(FsManagerLocator.java:60)
at java.lang.Class.initializeClass(libgcj.so.10)
...9 more

Am I doing something wrong?


Replies (1)

RE: Error when installing on Linux - Added by Matthieu Laborie over 6 years ago

Maybe you are using a wromg jdk, try using oracle's one.

Regards

    (1-1/1)