Project

General

Profile

Alfresco 4.2.d + beCPG 1.5a

Added by Fabrizio de Ceglia almost 6 years ago

Hi all,

i want to install beCPG 1.5a on Alfresco 4.2.d.
I've downloaded the file from https://www.becpg.fr/redmine/projects/designer/files, and followed the INSTALL.txt instruction:

1 - Install AMPS

java jar $ALF/bin/alfresco-mmt.jar install becpg-controls-core$BECPG_VERSION.amp $SERVER/webapps/alfresco.war force
java -jar $ALF/bin/alfresco-mmt.jar install becpg-controls-share
$BECPG_VERSION.amp $SERVER/webapps/share.war force
java -jar $ALF/bin/alfresco-mmt.jar install becpg-designer-core
$BECPG_VERSION.amp $SERVER/webapps/alfresco.war force
java -jar $ALF/bin/alfresco-mmt.jar install becpg-designer-share
$BECPG_VERSION.amp $SERVER/webapps/share.war -force

2 - Start alfresco

./alfresco.sh start

3 - Open the modeler

go to http://localhost:8080/share/page/model-designer

After the install from the terminal, the page "http://localhost:8080/share/page/model-designer" not exist.

Where am i doing wrong?

Cheers from Italy!


Replies (16)

RE: Alfresco 4.2.d + beCPG 1.5a - Added by Fabrizio de Ceglia almost 6 years ago

I've attacched to this message the catalina.out file. it contains a lot of error related to the beCPG exrtension

RE: Alfresco 4.2.d + beCPG 1.5a - Added by Matthieu Laborie almost 6 years ago

Hi,

It seems that amps are not deployed. You should have

07:59 17/10/13 [becpg-core] INFO [ModuleServiceImpl] Starting module 'becpg-designer-core' version 1.5.3.
07:59 17/10/13 [becpg-core] INFO [ModuleServiceImpl] Starting module 'becpg-core' version 1.5.2.

On your logs. Deployment hasn't been test yet with 4.2.d, if you succeed please let me know.

Regards
Matthieu

RE: Alfresco 4.2.d + beCPG 1.5a - Added by Fabrizio de Ceglia almost 6 years ago

Hi,

first of all thx for the reply.

You mean i've to first install the amp e then deploy?

how to deploy the amp? using this page ? --> http://127.0.0.1:8080/share/service/modules/deploy

thx ;)

RE: Alfresco 4.2.d + beCPG 1.5a - Added by Fabrizio de Ceglia almost 6 years ago

i've tried this steps:

1) append this code to share-config-custom.xml:
<config evaluator="string-compare" condition="WebFramework" >
<web-framework>
<module-deployment>
<mode>manual</mode>
<enable-auto-deploy-modules>true</enable-auto-deploy-modules>
</module-deployment>
</web-framework>
</config>

but here http://localhost:8080/share/service/modules/deploy nothing change.

RE: Alfresco 4.2.d + beCPG 1.5a - Added by Matthieu Laborie almost 6 years ago

Hi,

You can try the new release: https://www.becpg.fr/redmine/news/8 which should fix your issue.

Regards

RE: [FIXED] Alfresco 4.2.d + beCPG 1.5a - Added by Fabrizio de Ceglia almost 6 years ago

Hi Matthieu,

i've installed the 4.2.e release of Alfresco and then the new beCPG 1.5b following the instruction on the txt file.

But the http://localhost:8080/share/page/model-designer give me 404 error code...

RE: [FIXED] Alfresco 4.2.d + beCPG 1.5a - Added by Matthieu Laborie almost 6 years ago

Hi,

Can you join the catalina.out and more info about your installation steps.

Regards

RE: [FIXED] Alfresco 4.2.d + beCPG 1.5a - Added by Fabrizio de Ceglia almost 6 years ago

hi,

first, i've installed the last alfresco 4.2.e.

so i've installed the beCPG 1.5b following the instruction in the "install.txt" file:

1 - Install AMPS

java jar $ALF/bin/alfresco-mmt.jar install becpg-controls-core$BECPG_VERSION.amp $SERVER/webapps/alfresco.war force yep
java -jar $ALF/bin/alfresco-mmt.jar install becpg-controls-share
$BECPG_VERSION.amp $SERVER/webapps/share.war force yep
java -jar $ALF/bin/alfresco-mmt.jar install becpg-designer-core
$BECPG_VERSION.amp $SERVER/webapps/alfresco.war force yep
java -jar $ALF/bin/alfresco-mmt.jar install becpg-designer-share
$BECPG_VERSION.amp

i'va attacched the catalina.out file ;)

RE: [FIXED] Alfresco 4.2.d + beCPG 1.5a - Added by Fabrizio de Ceglia almost 6 years ago

sorry,

java jar $ALF/bin/alfresco-mmt.jar install becpg-controls-core$BECPG_VERSION.amp $SERVER/webapps/alfresco.war force
java -jar $ALF/bin/alfresco-mmt.jar install becpg-controls-share
$BECPG_VERSION.amp $SERVER/webapps/share.war force
java -jar $ALF/bin/alfresco-mmt.jar install becpg-designer-core
$BECPG_VERSION.amp $SERVER/webapps/alfresco.war force
java -jar $ALF/bin/alfresco-mmt.jar install becpg-designer-share
$BECPG_VERSION.amp $SERVER/webapps/share.war -force

Fabrizio de Ceglia a écrit :

hi,

first, i've installed the last alfresco 4.2.e.

so i've installed the beCPG 1.5b following the instruction in the "install.txt" file:

1 - Install AMPS

java jar $ALF/bin/alfresco-mmt.jar install becpg-controls-core$BECPG_VERSION.amp $SERVER/webapps/alfresco.war force yep
java -jar $ALF/bin/alfresco-mmt.jar install becpg-controls-share
$BECPG_VERSION.amp $SERVER/webapps/share.war force yep
java -jar $ALF/bin/alfresco-mmt.jar install becpg-designer-core
$BECPG_VERSION.amp $SERVER/webapps/alfresco.war force yep
java -jar $ALF/bin/alfresco-mmt.jar install becpg-designer-share
$BECPG_VERSION.amp

i'va attacched the catalina.out file ;)

RE: [FIXED] Alfresco 4.2.d + beCPG 1.5a - Added by Matthieu Laborie almost 6 years ago

Hi,

In your log :
2013-11-14 16:08:52,170 INFO [repo.module.ModuleServiceImpl] [localhost-startStop-1] Found 1 module(s).
2013-11-14 16:08:52,412 INFO [repo.module.ModuleServiceImpl] [localhost-startStop-1] Starting module 'org.alfresco.module.vti' version 1.3

You don't have the amp modules installed please verify your install command

$BECPG_VERSION --> should correspond to the amp file name
and $SERVER to where you have installed you alfresco war files

Regards

RE: [FIXED] Alfresco 4.2.d + beCPG 1.5a - Added by Baaka Tsutskhvashvili almost 6 years ago

hi,
same problem: 404 error code
Alfresco version 4.2e

RE: [FIXED] Alfresco 4.2.d + beCPG 1.5a - Added by Robert Ross almost 6 years ago

Same problem here. AMP files are in the proper directories and permissions are correct. Followed instructions in INSTALL readme. No change to Alfresco GUI and 404 error when accessed directly. Log file doesn't mention finding the modules.

RE: [FIXED] Alfresco 4.2.d + beCPG 1.5a - Added by Matthieu Laborie almost 6 years ago

Hi all,

What is the output or your amps commands ?

For me for exemple :

java -jar /opt/becpg/becpg-tc-server/deploy/alfresco-mmt.jar install becpg-controls/becpg-controls-core/target/becpg-controls-core-1.5.4.amp /opt/becpg/becpg-tc-server/instances/alfresco42/webapps/alfresco.war -force

Gives output:

 - WARNING: The file '/WEB-INF/classes/alfresco/templates/webscripts/org/alfresco/slingshot/datalists/filters.lib.js' is being overwritten by this module. The original has been backed-up to '/WEB-INF/classes/alfresco/module/backup/1e047a9b-4dc6-11e3-87e4-251c77cc65d4.bin'
   - WARNING: The file '/WEB-INF/classes/alfresco/templates/webscripts/org/alfresco/slingshot/datalists/data.post.json.js' is being overwritten by this module. The original has been backed-up to '/WEB-INF/classes/alfresco/module/backup/1f121a0c-4dc6-11e3-87e4-251c77cc65d4.bin'

Then

java -jar /opt/becpg/becpg-tc-server/deploy/alfresco-mmt.jar list /opt/becpg/becpg-tc-server/instances/alfresco42/webapps/alfresco.war

Should give

Module 'becpg-controls-core' installed in '/opt/becpg/becpg-tc-server/instances/alfresco42/webapps/alfresco.war'
- Title: beCPG Controls core
- Version: 1.5.4
- Install Date: Fri Nov 15 08:18:27 CET 2013
- Description: beCPG Controls

And so on.

Please provide as mutch log/infos as possible.
If README is not clear enought on how to install please contribute easier description or alternative ways or translation.
Tell me also about your env (windows, linux , ...)

Regards

RE: Alfresco 4.2.d + beCPG 1.5a - Added by Matthieu Laborie almost 6 years ago

The tar.gz file was containing older AMPs, I've updated a new one under files.

Regards

RE: Alfresco 4.2.d + beCPG 1.5a - Added by Fabrizio de Ceglia almost 6 years ago

nothig, the http://127.0.0.1:8080/share/page/model-designer page gives me 404 error (i've tried on a fresh install of alfresco 4.2.e & 4.2.d)

is it possible to start the model designer in another way?

regards

RE: Alfresco 4.2.d + beCPG 1.5a - Added by dan biggins over 5 years ago

FWIW, I had the same problem: no problem installing AMPs, no errors, 'Starting module 'becpg-designer-core'...' for designer and core showed up as expected. I couldn't see the Dropdown on the Admin menu until I deleted the unWar'd share directory in the webapps directory. After a restart of the tomcat instance, directory was recreated, and everything worked great.

    (1-16/16)